Omitir navegación
Ampliar
Habilitar TLS v1.2 en SoapUI
ID de respuesta 8869   |   Revisado 30/10/2018

¿Cómo puedo habilitar el uso de TLS v1.2 en SoapUI?

Ambiente:

Aplica a todas las versiones de Oracle Field Service (OFS)

Problema:

No puedo enviar peticiones soap a OFS empleando SoapUI

Escenario de Caso de Uso:

En el ambiente OFS ha sido deshabilitado el uso de los protocolos SSLv3, TLS v1.0 y TLS v1.1 pero mi sitio se encuentra en AKAMAI y estos protocolos aún se encuentran habilitados del lado de AKAMAI.

Solución:

Al enviar desde SoapUI una petición soap al WSDL deseado, por ejemplo: https://api.etadirect.com/soap/inbound/?wsdl, SoapUI se conectará a AKAMAI empleando un protocolo inferior a TLS v1.2 porque AKAMAI soporta estos protocolos hasta la desactivación oficial de  los mismos en Febrero 16 para ambientes TEST de OFSC y Marzo 11 para los ambientes productivos de OFS.

Al enviar desde AKAMAI una petición soap a OFS empleando un protocolo no soportado, el llamado falla y un error similar a "HTTP Error 403 Access Denied" es devuelto al cliente.

Para habilitar en SoapUI el envío de llamados empleando TLS v1.2, es necesario aplicar la siguiente configuración:

1. Ubique el directorio SoapUI, ubicado generalmente en C:\Archivos de Programa\SmartBear\SoapUI

2. Abra el directorio "bin"

3. Empleando un editor de texto, abra el archivo  "SoapUI-{versión}.vmoptions". {versión} hace referencia a su versión de SoapUI, por ejemplo: 5.1.2, 5.2.1, etc.

4. Agregue esta nueva línea al archivo: -Dsoapui.https.protocols=TLSv1.2

5. Guarde el cambio realizado. Es posible que requiera permisos de administrador para guardar el archivo en el directorio existente.

Una vez aplicado el cambio, abra SoapUI y valide la conectividad.

Lenguajes disponibles para esta Respuesta:

Notificarme
La página se refrescará al enviar. Las entradas pendientes se perderán.